summary refs log tree commit diff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-06-28 15:22:49 +0000
committerRicardo Wurmus <rekado@elephly.net>2022-06-30 15:17:58 +0200
commitc3c8b5e60a8a49a1579c838f1f4235837d60f2c2 (patch)
tree352b2c58edc1ce26daf3e9f053c771b794c5b2b2
parenta672682997bce7baba46c9e6e91c2b3f84b3fe50 (diff)
downloadguix-c3c8b5e60a8a49a1579c838f1f4235837d60f2c2.tar.gz
gnu: Add r-mathjaxr.
* gnu/packages/cran.scm (r-mathjaxr): New variable.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm48
1 files changed, 47 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 96dca393e6..93ba3f2bb9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35,7 +35,8 @@
 ;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
 ;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2022 Navid Afkhami  <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -33438,3 +33439,48 @@ jitterplot, or half violinplot and half dotplot.")
 coefficients or scattering amplitudes, for seismological P and S-waves at an
 interface.")
     (license license:gpl2+)))
+
+(define-public r-mathjaxr
+  (package
+    (name "r-mathjaxr")
+    (version "1.6-0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "mathjaxr" version))
+              (sha256
+               (base32
+                "0yf1sfkb2kjsplipl2v4k2gp20li9xzsynclg228sy0v243pdi7c"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  (delete-file-recursively "src/mathjax/es5/input")
+                  (delete-file-recursively "src/mathjax/es5/output")
+                  (delete-file "src/mathjax/es5/tex-chtml-full.js")))))
+    (properties `((upstream-name . "mathjaxr")))
+    (build-system r-build-system)
+    (arguments
+     (list
+      #:phases
+      `(modify-phases %standard-phases
+         (add-after 'unpack 'use-js-mathjax
+           (lambda* (#:key inputs #:allow-other-keys)
+             (symlink
+              (search-input-directory
+               inputs "/share/javascript/mathjax/es5/output")
+              "src/mathjax/es5/output")
+             (symlink
+              (search-input-directory
+               inputs "/share/javascript/mathjax/es5/input")
+              "src/mathjax/es5/input")
+             (symlink
+              (search-input-file
+               inputs "/share/javascript/mathjax/es5/tex-chtml-full.js")
+              "src/mathjax/es5/tex-chtml-full.js"))))))
+    (inputs
+     (list js-mathjax-for-r-mathjaxr))
+    (home-page "https://github.com/wviechtb/mathjaxr")
+    (synopsis "Use Mathjax in Rd Files")
+    (description
+     "This package provides MathJax and macros to enable its use within Rd files
+for rendering equations in the HTML help files.")
+    (license (list license:asl2.0 license:gpl3))))