summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 15:55:37 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:27 -0600
commitcab88488e937e677d1b0aef39a5ca926a54eced2 (patch)
treea4861faeb97922f83852f060fa5b58f8f18e8bb2
parenta7a75c87b05e139253753655f236f3ad5877317c (diff)
downloadguix-cab88488e937e677d1b0aef39a5ca926a54eced2.tar.gz
gnu: Add Text-Glob.
* gnu/packages/perl.scm (perl-text-glob): New variable.
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fd5a0e6b37..caa129264b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -938,6 +938,26 @@ hooking into done_testing as well as via an END block.  You can declare a
 plan, or not, and things will still Just Work.")
     (license (package-license perl))))
 
+(define-public perl-text-glob
+  (package
+    (name "perl-text-glob")
+    (version "0.09")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RC/RCLAMP/"
+                           "Text-Glob-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0lr76wrsj8wcxrq4wi8z1640w4dmdbkznp06q744rg3g0bd238d5"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Text-Glob")
+    (synopsis "Match globbing patterns against text")
+    (description "Text::Glob implements glob(3) style matching that can be
+used to match against text, rather than fetching names from a filesystem.  If
+you want to do full file globbing use the File::Glob module instead.")
+    (license (package-license perl))))
+
 (define-public perl-try-tiny
   (package
     (name "perl-try-tiny")