summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-02-12 09:30:18 +0000
committerChristopher Baines <mail@cbaines.net>2020-02-12 09:32:23 +0000
commitcd820bf78843aeaebf5e3cf6a4d3a43f5531d267 (patch)
treebf12962e71e2a9e8c57733db10d26a9e0bfecd63
parent7ad122007dc4fc9ab6bab9a17cdef6cbab68d20b (diff)
downloadguix-cd820bf78843aeaebf5e3cf6a4d3a43f5531d267.tar.gz
gnu: subversion: Disable parallel tests.
These seem to work fine on x86_64-linux, but on i686-linux some tests fail
when running in parallel.

FAIL:  fs-fs-pack-test 4: commit to a packed FSFS filesystem
FAIL:  fs-test: Unknown test failure; see tests.log.
FAIL:  io-test: Unknown test failure; see tests.log.
FAIL:  op-depth-test: Unknown test failure; see tests.log.
FAIL:  wc-test: Unknown test failure; see tests.log.
Summary of test results:
  2243 tests PASSED
  96 tests SKIPPED
  43 tests XFAILED
  5 tests FAILED
SUMMARY: Some tests failed.

* gnu/packages/version-control.scm (subversion)[arguments]: Add
 #:parallel-tests? #f and use this in the 'set-PARALLEL phase.
-rw-r--r--gnu/packages/version-control.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 65ac48188c..e2a06dee59 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1430,7 +1430,9 @@ following features:
                "19zc215mhpnm92mlyl5jbv57r5zqp6cavr3s2g9yglp6j4kfgj0q"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
+     '(#:parallel-tests? #f             ; TODO Seems to cause test failures on
+                                        ; i686-linux
+       #:phases
        (modify-phases %standard-phases
          (add-after 'configure 'patch-libtool-wrapper-ls
            (lambda* (#:key inputs #:allow-other-keys)
@@ -1449,8 +1451,10 @@ following features:
                (("#!/bin/sh") (string-append "#!" (which "sh"))))
              #t))
          (add-before 'check 'set-PARALLEL
-           (lambda _
-             (setenv "PARALLEL" (number->string (parallel-job-count)))
+           (lambda* (#:key parallel-tests? #:allow-other-keys)
+             (if parallel-tests?
+                 (setenv "PARALLEL" (number->string (parallel-job-count)))
+                 (simple-format #t "parallel-tests? are disabled\n"))
              #t))
          (add-after 'install 'install-perl-bindings
            (lambda* (#:key outputs #:allow-other-keys)