summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-17 16:37:21 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-17 16:37:42 +0200
commitd1b375402f5680b1e5a77dd1fb77e1e9d94625d1 (patch)
tree6adb2cbaf5f747ed0c78a5eb0a19cfa9b3a45eeb
parent6441d8ad08ee9d47a3f4ea90d9a2ff633b4cf888 (diff)
downloadguix-d1b375402f5680b1e5a77dd1fb77e1e9d94625d1.tar.gz
gnu: ipset: Omit static library.
* gnu/packages/linux.scm (ipset)[arguments]: Add "--disable-static" to
the #:configure-flags.
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 80c0d8d913..5c21515e20 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8408,7 +8408,8 @@ receiving.  It is dedicated to the PL011 UART of the Raspberry Pi.")
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (arguments
-     `(#:configure-flags '("--with-kmod=no")))
+     `(#:configure-flags '("--disable-static"
+                           "--with-kmod=no")))
     (home-page "https://ipset.netfilter.org/")
     (synopsis "Administration tool for IP sets")
     (description "IP sets are a framework inside the Linux 2.4.x and 2.6.x kernel which