summary refs log tree commit diff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-04-02 01:22:21 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-02 11:16:40 +0200
commitd36730477013cf561da8f90fb6e0c9532840b328 (patch)
treed643318df415fefbf7c80eca1cb6b86e3e4e12dc
parentbf155ce30cd417f8dba9ab04c1d39cc3249bb930 (diff)
downloadguix-d36730477013cf561da8f90fb6e0c9532840b328.tar.gz
gnu: darktable: Make some inputs native.
* gnu/packages/photo.scm (darktable)[inputs]: Move intltool, perl & pkg-config
from here...
[native-inputs]: ...to here.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/photo.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 585289daf1..7cb67dcbe6 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2020 Sebastian Schott <sschott@mailbox.org>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -483,6 +484,10 @@ photographic equipment.")
                      (string-append (assoc-ref inputs "ilmbase")
                                     "/include/OpenEXR:" (or (getenv "CPATH") "")))
              #t)))))
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)))
     (inputs
      `(("libxslt" ,libxslt)
        ("libxml2" ,libxml2)
@@ -502,9 +507,6 @@ photographic equipment.")
        ("ilmbase" ,ilmbase)
        ("libsoup" ,libsoup)
        ("python-jsonschema" ,python-jsonschema)
-       ("intltool" ,intltool)
-       ("perl" ,perl)
-       ("pkg-config" ,pkg-config)
        ("libwebp" ,libwebp)
        ("lensfun" ,lensfun)
        ("librsvg" ,librsvg)