summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-20 15:55:26 +0200
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:57 -0400
commitd548fa91446d4738adb1a5289746bf9363fff398 (patch)
treeaa3bb80805450318f771e56539c5689a9e0101ec
parentfc29c80b9635ff490bcc768c774442043cb1e231 (diff)
downloadguix-d548fa91446d4738adb1a5289746bf9363fff398.tar.gz
gnu: appstream-glib: Fix failing tests.
* gnu/packages/glib.scm (appstream-glib)[arguments]<#:phases>{set-home}: Add a
new phase 'set-home' for tests that want to write to $HOME.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/glib.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 91ef45099c..8ed1e3a944 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1107,7 +1107,11 @@ Some codes examples can be find at:
            (lambda _
              (substitute* "libappstream-glib/as-self-test.c"
                (("g_test_add_func.*as_test_store_local_appdata_func);") ""))
-             #t)))))
+             #t))
+         (add-before 'check 'set-home
+           (lambda _
+             ;; Some tests want write access there.
+             (setenv "HOME" "/tmp"))))))
     (home-page "https://github.com/hughsie/appstream-glib")
     (synopsis "Library for reading and writing AppStream metadata")
     (description "This library provides objects and helper methods to help