summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-08 17:41:58 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-08 21:20:13 +0200
commitf78975c8e098e38494a697aa88c9ca5395975041 (patch)
treea2b017b8ebb1510e39646a83dbbf8aa41ecac55e
parentc46c8531dd35db5af0e37a9230acafa9215080ef (diff)
downloadguix-f78975c8e098e38494a697aa88c9ca5395975041.tar.gz
gnu: python-h2: Respect "--without-tests".
* gnu/packages/python-web.scm
  (python-h2)[arguments]<#:phases>{check}: Respect #:tests?.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d175fbb061..8ec6864b8b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -937,9 +937,10 @@ and that could be anything you want.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             (invoke "pytest" "-vv" "test"))))))
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "pytest" "-vv" "test")))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (propagated-inputs