summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-09 22:20:42 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-09 22:21:27 +0100
commit09a8778f73c64c2c1542bfa8552e4f5c3121ef4d (patch)
treeba6219a5124607e25c8c5c837c777a07bb20372e
parent56aa03b0c2804ca8694d094b038f47299651fd09 (diff)
downloadguix-09a8778f73c64c2c1542bfa8552e4f5c3121ef4d.tar.gz
gnu: Add perl-encode-locale.
* gnu/packages/web.scm (perl-encode-locale): New variable.
-rw-r--r--gnu/packages/web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 37c764c59e..f8d052600a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -364,3 +364,29 @@ HTTP/1.1.")
      "The File::Listing module exports a single function called parse_dir(),
 which can be used to parse directory listings.")
     (home-page "http://search.cpan.org/~gaas/File-Listing/")))
+
+(define-public perl-encode-locale
+  (package
+    (name "perl-encode-locale")
+    (version "1.03")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "mirror://cpan/authors/id/G/GA/GAAS/Encode-Locale-"
+                   version ".tar.gz"))
+             (sha256
+              (base32
+               "0m9d1vdphlyzybgmdanipwd9ndfvyjgk3hzw250r299jjgh3fqzp"))))
+    (build-system perl-build-system)
+    (license (package-license perl))
+    (synopsis "Perl locale encoding determination")
+    (description
+     "The POSIX locale system is used to specify both the language
+conventions requested by the user and the preferred character set to consume
+and output.  The Encode::Locale module looks up the charset and encoding
+(called a CODESET in the locale jargon) and arranges for the Encode module
+to know this encoding under the name \"locale\".  It means bytes obtained
+from the environment can be converted to Unicode strings by calling
+Encode::encode(locale => $bytes) and converted back again with
+Encode::decode(locale => $string).")
+    (home-page "http://search.cpan.org/~gaas/Encode-Locale/")))