summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2023-02-09 12:33:28 +0400
committerAndrew Tropin <andrew@trop.in>2023-02-09 17:37:00 +0400
commit1378bb5348cc0f4bec796ccf1a2632f08e42cb09 (patch)
tree43d33c08a00d96bba019b3cd4f4c57cf940973f3
parent8f9edc9ebca69fb2ee64e68f3854848338aaba3d (diff)
downloadguix-1378bb5348cc0f4bec796ccf1a2632f08e42cb09.tar.gz
gnu: tree-sitter: Update package style.
* gnu/packages/tree-sitter.scm (tree-sitter): Add gexps, remove trailing #t,
reformat code.
-rw-r--r--gnu/packages/tree-sitter.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index e6f0b5c71d..b0d4bb1c38 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -40,22 +40,19 @@
                (base32
                 "1nv2a2hr22w8ix71b6rkkxv9rfvhvwlmyql0g6lva9qzj4vy50p4"))
               (modules '((guix build utils)))
-              (snippet '(begin
-                          ;; Remove bundled ICU parts
-                          (delete-file-recursively "lib/src/unicode")
-                          #t))))
+              (snippet #~(begin
+                           ;; Remove bundled ICU parts
+                           (delete-file-recursively "lib/src/unicode")))))
     (build-system gnu-build-system)
     (inputs (list icu4c))
     (arguments
      (list #:phases
-           '(modify-phases %standard-phases
-              (delete 'configure))
+           #~(modify-phases %standard-phases
+               (delete 'configure))
            #:tests? #f ; there are no tests for the runtime library
            #:make-flags
-           #~(list (string-append "PREFIX="
-                                  #$output)
-                   (string-append "CC="
-                                  #$(cc-for-target)))))
+           #~(list (string-append "PREFIX=" #$output)
+                   (string-append "CC=" #$(cc-for-target)))))
     (home-page "https://tree-sitter.github.io/tree-sitter/")
     (synopsis "Incremental parsing system for programming tools")
     (description
@@ -73,6 +70,5 @@ Tree-sitter aims to be:
 can be embedded in any application
 @end itemize
 
-This package includes the @code{libtree-sitter} runtime library.
-")
+This package includes the @code{libtree-sitter} runtime library.")
     (license license:expat)))