summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-08-30 09:21:23 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-09-06 09:08:49 -0400
commit1415792a7c2faafe3d62c80358211db87a03020b (patch)
treefbd13f3868a2a53254e28496d1653b592aecfd89
parent96e76083b82659429cd46e9abe2323678fd98e87 (diff)
downloadguix-1415792a7c2faafe3d62c80358211db87a03020b.tar.gz
gnu: Add ruby-thread-safe.
* gnu/packages/ruby.scm (ruby-thread-safe): New variable.
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d3babbe5d2..60cee11356 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -921,3 +921,23 @@ Ruby.  It features syntax highlighting, a plugin architecture, runtime
 invocation, and source and documentation browsing.")
     (home-page "http://pryrepl.org")
     (license license:expat)))
+
+(define-public ruby-thread-safe
+  (package
+    (name "ruby-thread-safe")
+    (version "0.3.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "thread_safe" version))
+       (sha256
+        (base32
+         "1hq46wqsyylx5afkp6jmcihdpv4ynzzq9ygb6z2pb1cbz5js0gcr"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(#:tests? #f)) ; needs simplecov, among others
+    (synopsis "Thread-safe utilities for Ruby")
+    (description "The thread_safe library provides thread-safe collections and
+utilities for Ruby.")
+    (home-page "https://github.com/ruby-concurrency/thread_safe")
+    (license license:asl2.0)))