summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-17 00:10:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:19 +0200
commit176f5439fba5f90505810c4ef9abd379e9895e4d (patch)
treed98b50c40b6cb52bc10b9c9f2b75b5fb2b155206
parent5c7346c2345c48558c5b559c55c6b18cb6f07635 (diff)
downloadguix-176f5439fba5f90505810c4ef9abd379e9895e4d.tar.gz
gnu: texlive-lm: Refresh package definition.
* gnu/packages/tex.scm (texlive-lm): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[home-page]: Update URL.
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 18 insertions, 15 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 66e1a3b3fb..43156bf7f2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1398,21 +1398,24 @@ in LuaTeX.  It is required by the @code{luatexbase} package which uses
 
 (define-public texlive-lm
   (package
-    (inherit (simple-texlive-package
-              "texlive-lm"
-              (list "/doc/fonts/lm/"
-                    "/fonts/afm/public/lm/"
-                    "/fonts/enc/dvips/lm/"
-                    "/fonts/map/dvipdfm/lm/"
-                    "/fonts/map/dvips/lm/"
-                    "/fonts/opentype/public/lm/"
-                    "/fonts/tfm/public/lm/"
-                    "/fonts/type1/public/lm/"
-                    "/tex/latex/lm/")
-              (base32
-               "0yyk0dr4yms82mwy4dc03zf5igyhgcb65icdah042rk23rlpxygv")
-              #:trivial? #t))
-    (home-page "https://www.gust.org.pl/projects/e-foundry/latin-modern/")
+    (name "texlive-lm")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/lm/"
+                   "fonts/afm/public/lm/"
+                   "fonts/enc/dvips/lm/"
+                   "fonts/map/dvipdfm/lm/"
+                   "fonts/map/dvips/lm/"
+                   "fonts/opentype/public/lm/"
+                   "fonts/tfm/public/lm/"
+                   "fonts/type1/public/lm/"
+                   "tex/latex/lm/")
+             (base32
+              "0yyk0dr4yms82mwy4dc03zf5igyhgcb65icdah042rk23rlpxygv")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/lm")
     (synopsis "Latin Modern family of fonts")
     (description "The Latin Modern fonts are derived from the famous Computer
 Modern fonts designed by Donald E. Knuth and described in Volume E of his