summary refs log tree commit diff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-18 17:41:21 +0800
committer宋文武 <iyzsong@member.fsf.org>2020-01-18 17:42:46 +0800
commit1cc9c38e902aeb03295e9728b4cf40ff2b302716 (patch)
treefdcd68ae74d8152b31d26729bde6da2a5f2a92ae
parente24c672e740664c1340a4ff8bf43a21b4bd3e5d1 (diff)
downloadguix-1cc9c38e902aeb03295e9728b4cf40ff2b302716.tar.gz
gnu: Add python-aionotify.
* gnu/packages/python-xyz.scm (python-aionotify): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e14bbc1bbd..2bef867630 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17150,3 +17150,25 @@ Notation (CSON).")
      "The package asynctest is built on top of the standard unittest module
 and cuts down boilerplate code when testing libraries for asyncio.")
     (license license:asl2.0)))
+
+(define-public python-aionotify
+  (package
+    (name "python-aionotify")
+    (version "0.2.0")
+    (source
+     (origin
+       ;; Source tarball on PyPi lacks tests
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rbarrois/aionotify")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1sk9i8czxgsbrswsf1nlb4c82vgnlzi8zrvrxdip92w2z8hqh43y"))))
+    (build-system python-build-system)
+    (native-inputs `(("python-asynctest" ,python-asynctest)))
+    (home-page "https://github.com/rbarrois/aionotify")
+    (synopsis "Asyncio-powered inotify library")
+    (description
+     "@code{aionotify} is a simple, asyncio-based inotify library.")
+    (license license:bsd-3)))