summary refs log tree commit diff
diff options
context:
space:
mode:
authorAdam Massmann <massmannak@gmail.com>2018-04-04 02:10:32 -0400
committerEric Bavier <bavier@member.fsf.org>2018-04-04 09:35:21 -0500
commit2514fc1d69ec556c9c18d2463a892f43fa175557 (patch)
treede9d5b2b99665b5b276970295d710f779623a67c
parentc2b2f0c86691f6d76f528b6366c866b8f3665c3c (diff)
downloadguix-2514fc1d69ec556c9c18d2463a892f43fa175557.tar.gz
gnu: Add python-pybtex
* gnu/packages/python.scm (python-pybtex): New variable.

Signed-off-by: Eric Bavier <bavier@member.fsf.org>
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8d15c9a214..e5b74a57f7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13101,3 +13101,29 @@ file system events on Linux.")
     (synopsis "Work with LaTeX code in Python")
     (description "Lexer and codec to work with LaTeX code in Python.")
     (license license:expat)))
+
+(define-public python-pybtex
+  (package
+    (name "python-pybtex")
+    (version "0.21")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pybtex" version))
+       (sha256
+        (base32
+         "00300j8dn5pxq4ndxmfmbmycg2znawkqs49val2x6jlmfiy6r2mg"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (inputs
+     `(("python-latexcodec" ,python-latexcodec)
+       ("python-pyyaml" ,python-pyyaml)
+       ("python-six" ,python-six)))
+    (arguments
+     `(#:test-target "nosetests"))
+    (home-page "https://pybtex.org/")
+    (synopsis "BibTeX-compatible bibliography processor")
+    (description "Pybtex is a BibTeX-compatible bibliography processor written
+in Python.  You can simply type pybtex instead of bibtex.")
+    (license license:expat)))