summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-11 11:12:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-11 11:13:56 +0200
commit261e4214592709d5e4be1c8a7abdd92e9b1d253c (patch)
tree25a0cce2f109e1099ada1a40c2f375a3be7ed338
parent8189ce6f05ebc49fc85934bdd1c81f8d43496a93 (diff)
downloadguix-261e4214592709d5e4be1c8a7abdd92e9b1d253c.tar.gz
gnu: python-pyclipper: Enable tests.
* gnu/packages/python.scm (python-pyclipper)[arguments]: Enable tests.
[native-inputs]: Add python-pytest, python-pytest-runner,
python-unittest2.
-rw-r--r--gnu/packages/python.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e8d8daae40..cce995535a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12911,8 +12911,7 @@ belong to tagged versions.")
           (delete-file "pyclipper/pyclipper.cpp") #t))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f  ; 8 Tests fail, 37 succeed
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          (add-before 'build 'cythonize-sources
            (lambda _
@@ -12922,6 +12921,9 @@ belong to tagged versions.")
      `(("python-setuptools-scm-git-archive" ,python-setuptools-scm-git-archive)))
     (native-inputs
      `(("python-cython" ,python-cython)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-runner" ,python-pytest-runner)
+       ("python-unittest2" ,python-unittest2)
        ("unzip" ,unzip)))
     (home-page "https://github.com/greginvm/pyclipper")
     (synopsis "Wrapper for Angus Johnson's Clipper library")