summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 13:24:57 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:20 -0400
commit33a59643801b0bf20f023bd0d20e1ed2fad934a1 (patch)
tree7e4d0a7ec900054e63524b5641f062123731b40d
parentb71f037f1f44aeb80a53fb0b5693b1082cd90963 (diff)
downloadguix-33a59643801b0bf20f023bd0d20e1ed2fad934a1.tar.gz
gnu: at-spi2-core: Fix documentation.
* gnu/packages/gtk.scm (at-spi2-core) [arguments]<#:phases>['patch-docbook-sgml]: New phase.
[native-inputs]: Add docbook-xml.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 387b24b27e..2615d84170 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -717,6 +717,14 @@ scaled, composited, modified, saved, or rendered.")
            (lambda* (#:key outputs #:allow-other-keys)
              (mkdir-p (string-append (assoc-ref outputs "doc") "/share"))
              #t))
+         (add-after 'unpack 'patch-docbook-sgml
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let* ((xmldoc (string-append (assoc-ref inputs "docbook-xml")
+                                           "/xml/dtd/docbook")))
+               (substitute* "doc/libatspi/libatspi-docs.sgml"
+                 (("http://.*/docbookx\\.dtd")
+                  (string-append xmldoc "/docbookx.dtd")))
+               #t)))
          (add-after 'install 'move-documentation
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
@@ -745,7 +753,8 @@ scaled, composited, modified, saved, or rendered.")
        ("libxi" ,libxi)
        ("libxtst" ,libxtst)))
     (native-inputs
-     `(("gettext" ,gettext-minimal)
+     `(("docbook-xml" ,docbook-xml-4.3)
+       ("gettext" ,gettext-minimal)
        ("glib" ,glib "bin")
        ("gobject-introspection" ,gobject-introspection)
        ("gtk-doc" ,gtk-doc)