summary refs log tree commit diff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2023-03-21 13:54:32 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2023-03-21 13:58:42 +0100
commit34f684371ee1bc4c16d46cd660207be97c5df321 (patch)
tree1e0f004ecd9067007f73512441f7c94b57c04548
parent9f882daf1194993716b3064f549a9f8d3a97277e (diff)
downloadguix-34f684371ee1bc4c16d46cd660207be97c5df321.tar.gz
gnu: Add python-libneuroml.
* gnu/packages/python-science.scm (python-libneuroml): New variable.
-rw-r--r--gnu/packages/python-science.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 6061b432a7..073243b63d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -76,7 +76,8 @@
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix utils)
-  #:use-module (guix build-system python))
+  #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject))
 
 (define-public python-scipy
   (package
@@ -1707,6 +1708,30 @@ tabular datasets.  This package provides the core modules of Vaex.")
 NeuroML2 models.")
     (license license:lgpl3)))
 
+(define-public python-libneuroml
+  (package
+    (name "python-libneuroml")
+    (version "0.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/NeuralEnsemble/libNeuroML.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0mrm4rd6x1sm6hkvhk20mkqp9q53sl3lbvq6hqzyymkw1iqq6bhy"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-lxml python-six))
+    (native-inputs (list python-pytest python-numpy python-tables))
+    (home-page "https://libneuroml.readthedocs.org/en/latest/")
+    (synopsis
+     "Python library for working with NeuroML descriptions of neuronal models")
+    (description
+     "This package provides a Python library for working with NeuroML descriptions of
+neuronal models")
+    (license license:bsd-3)))
+    
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar