summary refs log tree commit diff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2023-03-21 13:54:57 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2023-03-21 13:58:47 +0100
commit38b64d47ed3dfaeb63b859e7a8834e477ffed3a1 (patch)
treefcb151fff8e0c7ac0d665f853c62a909c8feb8f0
parent34f684371ee1bc4c16d46cd660207be97c5df321 (diff)
downloadguix-38b64d47ed3dfaeb63b859e7a8834e477ffed3a1.tar.gz
gnu: Add python-brian2tools.
* gnu/packages/machine-learning.scm (python-brian2tools): New variable.
-rw-r--r--gnu/packages/machine-learning.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 004568a77b..1fb341f7f0 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3858,3 +3858,31 @@ fi"
 is therefore designed to be easy to learn and use, highly flexible and
 easily extensible.")
     (license license:cecill)))
+
+(define-public python-brian2tools
+  (package
+    (name "python-brian2tools")
+    (version "0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "brian2tools" version))
+              (sha256
+               (base32
+                "0fn028mfy3qlzjkadd0wr5d7rcplijd5jphln414xifvvsb9jcc2"))))
+    (build-system python-build-system)
+    ;; Both pypi tarball and git repo lack test files.
+    (arguments (list #:tests? #f))
+    (propagated-inputs (list python-brian2
+                             python-libneuroml
+                             python-markdown-strings
+                             python-matplotlib
+                             python-pylems
+                             python-setuptools
+                             python-setuptools-scm))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/brian-team/brian2tools")
+    (synopsis "Tools for the Brian 2 simulator")
+    (description "Visualization and NeuroML import/export tools for the
+Brian 2 simulator.")
+    (license license:cecill)))
+