summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-09 16:24:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-10 15:48:51 +0100
commit3b9892ad07a943ff17f72377f6ca344041237979 (patch)
tree91526ef231bcc8d2f9b36952058f2b6fbea0b2ef
parentb8f6ead5faac3c1b9a8fa6e060c00cf0917e884e (diff)
downloadguix-3b9892ad07a943ff17f72377f6ca344041237979.tar.gz
gnu: python-hmmlearn: Update to 0.2.8.
* gnu/packages/machine-learning.scm (python-hmmlearn): Update to 0.2.8.
[arguments]: Use gexp; simplify 'check phase.
[propagated-inputs]: Remove python-cython.
-rw-r--r--gnu/packages/machine-learning.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 1cd430de5f..9aae8d8243 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2023 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -3371,27 +3371,26 @@ Python.")
 (define-public python-hmmlearn
   (package
     (name "python-hmmlearn")
-    (version "0.2.7")
+    (version "0.2.8")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "hmmlearn" version))
        (sha256
         (base32
-         "1qgnf1kdxicygy8nvpv866iqvwq0rc6xkd3s6slmvxvsy8h2fjvb"))))
+         "1yd5l9ra37mks41mn5bigav7xpb161a9yqlcnz4ir076vkik2sb9"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (with-directory-excursion (string-append (assoc-ref outputs "out") "/lib")
-                 (invoke "python" "-m" "pytest"))))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion (string-append #$output "/lib")
+                  (invoke "python" "-m" "pytest"))))))))
     (propagated-inputs
      (list pybind11
-           python-cython
            python-numpy
            python-scikit-learn
            python-scipy