summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 16:52:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:25 +0300
commit47f67c565b25a0c18e2fc2d4260fd5f1f8a673b0 (patch)
tree7692ea6a9336eaf08af268af5239126461decda6
parenta9db2df4dd0a11b8461d57dfd0029d73e4290a57 (diff)
downloadguix-47f67c565b25a0c18e2fc2d4260fd5f1f8a673b0.tar.gz
gnu: Add julia-stablerngs.
* gnu/packages/julia-xyz.scm (julia-stablerngs): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index dc2d0336a0..30775c7fa4 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1553,6 +1553,29 @@ cosine) integrals, eta, zeta, digamma, inverse digamma, trigamma, and
 polygamma functions.")
     (license license:expat)))
 
+(define-public julia-stablerngs
+  (package
+    (name "julia-stablerngs")
+    (version "1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaRandom/StableRNGs.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1cw4wc38qbgmrrx0jjwjhynnarrzjkh0yyz242zj272brbci7p1r"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/JuliaRandom/StableRNGs.jl")
+    (synopsis "Julia RNG with stable streams")
+    (description "This package intends to provide a simple RNG with stable
+streams, suitable for tests in packages which need reproducible streams of
+random numbers across Julia versions.  Indeed, the Julia RNGs provided by
+default are documented to have non-stable streams (which for example enables
+some performance improvements).")
+    (license license:expat)))
+
 (define-public julia-staticarrays
   (package
     (name "julia-staticarrays")