summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-06 01:20:51 +0200
committerMarius Bakke <marius@gnu.org>2021-05-06 19:10:04 +0200
commit4bdc52bc21d501c7d8e2b6d1d3951783288e0398 (patch)
tree715e2a95ce2756234cf3035f2c44af139709243a
parent0f056f2c3360fe43ed12a554cca34617435fe8ee (diff)
downloadguix-4bdc52bc21d501c7d8e2b6d1d3951783288e0398.tar.gz
gnu: gunicorn: Update to 2.1.0.
* gnu/packages/python-web.scm (gunicorn): Update to 2.1.0.
[arguments]: Ignore one test that cannot run in the build container.
[native-inputs]: Add PYTHON-GEVENT.
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4d6d4788a8..5897893de3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4688,14 +4688,14 @@ event loop.  It is implemented in Cython and uses libuv under the hood.")
 (define-public gunicorn
   (package
     (name "gunicorn")
-    (version "20.0.4")
+    (version "20.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "gunicorn" version))
        (sha256
         (base32
-         "09n6fc019bgrvph1s5h1lwhn2avcsprw6ncd203qhra3i8mvn10r"))))
+         "1s7670qw36x90bgmazmgib170i5gnpyb2ypxzlla7y0mpasniag0"))))
     (outputs '("out" "doc"))
     (build-system python-build-system)
     (arguments
@@ -4713,7 +4713,11 @@ event loop.  It is implemented in Cython and uses libuv under the hood.")
                  (begin
                    (setenv "PYTHONPATH"
                            (string-append ".:" (getenv "PYTHONPATH")))
-                   (invoke "pytest" "-vv"))
+                   (invoke "pytest" "-vv"
+                           ;; Disable the geventlet tests because eventlet uses
+                           ;; dnspython, which does not work in the build
+                           ;; container due to lack of /etc/resolv.conf, etc.
+                           "--ignore=tests/workers/test_geventlet.py"))
                  (format #t "test suite not run~%"))))
          (add-after 'install 'install-doc
            (lambda* (#:key outputs #:allow-other-keys)
@@ -4749,6 +4753,7 @@ event loop.  It is implemented in Cython and uses libuv under the hood.")
     (native-inputs
      `(("binutils" ,binutils)  ;; for ctypes.util.find_library()
        ("python-aiohttp" ,python-aiohttp)
+       ("python-gevent" ,python-gevent)
        ("python-pytest" ,python-pytest)
        ("python-pytest-cov" ,python-pytest-cov)
        ("python-sphinx" ,python-sphinx)