summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 23:39:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:16 +0200
commit6092f24536962ef8e66f7942c16ae5fb3983a2e4 (patch)
tree321e4e800d7027d3e062346f9626866a1b6d0806
parent2efc69ca6b7a9c1eb0d7c906dfc187d96c5f978f (diff)
downloadguix-6092f24536962ef8e66f7942c16ae5fb3983a2e4.tar.gz
gnu: texlive-dehyph-exptl: Refresh package definition.
* gnu/packages/tex.scm (texlive-dehyph-exptl): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 17 insertions, 13 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d3b988d0f6..7a7bc79038 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2992,20 +2992,24 @@ patterns as well.")
 
 (define-public texlive-dehyph-exptl
   (package
-    (inherit (simple-texlive-package
-              "texlive-dehyph-exptl"
-              (list "/tex/generic/dehyph-exptl/"
-                    "/doc/generic/dehyph-exptl/")
-              (base32
-               "0l57a0r4gycp94kz6lrxqvh9m57j2shmbr2laf5zjb0qnrisq46d")
-              #:trivial? #t))
-    (propagated-inputs
-     (list texlive-hyphen-base texlive-hyph-utf8))
-    (home-page "http://projekte.dante.de/Trennmuster/WebHome")
+    (name "texlive-dehyph-exptl")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/dehyph-exptl/"
+                   "tex/generic/dehyph-exptl/")
+             (base32
+              "0l57a0r4gycp94kz6lrxqvh9m57j2shmbr2laf5zjb0qnrisq46d")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:texlive-latex-base #f))
+    (propagated-inputs (list texlive-hyph-utf8 texlive-hyphen-base))
+    (home-page "https://ctan.org/pkg/dehyph-exptl")
     (synopsis "Hyphenation patterns for German")
-    (description "The package provides experimental hyphenation patterns for
-the German language, covering both traditional and reformed orthography.  The
-patterns can be used with packages Babel and hyphsubst from the Oberdiek
+    (description
+     "The package provides experimental hyphenation patterns for the German
+language, covering both traditional and reformed orthography.  The patterns
+can be used with packages Babel and @code{hyphsubst} from the Oberdiek
 bundle.")
     ;; Hyphenation patterns are under the Expat license; documentation is
     ;; under LPPL.