summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 17:56:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-18 20:56:07 +0300
commit61518390cde85beb85db44757bc2e1097f42736c (patch)
treec3a46c63903c689bb074ac88126f23977e6bfb42
parentc4d4e9e7465eff636f4972a93abd067a8383d533 (diff)
downloadguix-61518390cde85beb85db44757bc2e1097f42736c.tar.gz
gnu: Add rust-unsafe-libyaml-0.2.
* gnu/packages/crates-io.scm (rust-unsafe-libyaml-0.2): New variable.
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d03dc4235c..9a1d118601 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -70967,6 +70967,30 @@ clear display in the output.")
      "Traits and implementations for unchecked downcasting.")
     (license license:expat)))
 
+;; This package was originally transpiled from libyaml, but has seen development
+;; since then, showing that it is in its editable form.
+(define-public rust-unsafe-libyaml-0.2
+  (package
+    (name "rust-unsafe-libyaml")
+    (version "0.2.8")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "unsafe-libyaml" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "19l0v20x83dvxbr68rqvs9hvawaqd929hia1nldfahlhamm80r8q"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f  ; use of undeclared crate or module `unsafe_libyaml_test_suite`
+       #:cargo-development-inputs
+       (("rust-pretty-assertions" ,rust-pretty-assertions-1))))
+    (home-page "https://github.com/dtolnay/unsafe-libyaml")
+    (synopsis "Libyaml in rust")
+    (description "This package provides libyaml transpiled to rust by c2rust,
+with changes and updated applied to it.")
+    (license license:expat)))
+
 (define-public rust-unsafe-unwrap-0.1
   (package
     (name "rust-unsafe-unwrap")