summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-14 12:50:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 19:22:45 +0200
commit615d8b08ee102c803d13d47c4d7c404ef2fa5160 (patch)
treec67e6e4d60dee15464c77b3c918a4e4b90aead99
parenta1cfa757d75cf2b87a5298ce1ced9adf0c9e39b4 (diff)
downloadguix-615d8b08ee102c803d13d47c4d7c404ef2fa5160.tar.gz
gnu: Add julia-changesofvariables.
* gnu/packages/julia-xyz.scm (julia-changesofvariables): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 068b4742cd..405a631cc1 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -822,6 +822,33 @@ can be a test-only dependency, allowing it to have potentially heavy
 dependencies, while keeping @code{ChainRulesCore.jl} as light-weight as possible.")
     (license license:expat)))
 
+(define-public julia-changesofvariables
+  (package
+    (name "julia-changesofvariables")
+    (version "0.1.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaMath/ChangesOfVariables.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1migyhiqr1rq496302wlkb0s5l8zwqs97ajfkip0jzpvrk2s2xxy"))))
+    (build-system julia-build-system)
+    (arguments
+     ;; Pulls in ForwardDiff, would have a cyclical
+     ;; dependency with LogExpFunctions.
+     (list #:tests? #f))
+    (propagated-inputs
+     (list julia-chainrulescore))
+    (home-page "https://github.com/JuliaMath/ChangesOfVariables.jl")
+    (synopsis "Interface for transformation functions in Julia")
+    (description "This package defines functionality to calculate volume element
+changes for functions that perform a change of variables (like coordinate
+transformations).")
+    (license license:expat)))
+
 (define-public julia-codeczlib
   (package
     (name "julia-codeczlib")