summary refs log tree commit diff
diff options
context:
space:
mode:
authorPeter Polidoro <peter@polidoro.io>2022-10-13 15:42:53 -0400
committerChristopher Baines <mail@cbaines.net>2022-12-06 11:14:53 +0000
commit6219491c47f20aef6bc8523110936924e4d3d785 (patch)
tree29df423c53fa9bffb76a9de6f81bbf9b09833711
parent346469e04eeca68634e8b6cce7bb1f953aaef226 (diff)
downloadguix-6219491c47f20aef6bc8523110936924e4d3d785.tar.gz
gnu: Add python-pint.
* gnu/packages/python-xyz.scm (python-pint): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b0202853d8..b830ade9ca 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -924,6 +924,36 @@ variables into the markdown template")
 Markdown.  All extensions are found under the module namespace of pymdownx.")
     (license license:expat)))
 
+(define-public python-pint
+  (package
+    (name "python-pint")
+    (version "0.19.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "Pint" version))
+              (sha256
+               (base32
+                "1bsbiikm9i4saqc6mc3minkmrgnsgcg734agsvd7icqhyngrim71"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list python-pytest
+           python-pytest-cov
+           python-pytest-mpl
+           python-pytest-subtests
+           python-setuptools-scm
+           python-sparse
+           python-dask
+           python-xarray
+           python-distributed))
+    (home-page "https://github.com/hgrecco/pint")
+    (synopsis "Physical quantities module")
+    (description
+     "Pint is a Python package to define, operate and manipulate physical
+quantities: the product of a numerical value and a unit of measurement.  It
+allows arithmetic operations between them and conversions from and to
+different units.")
+    (license license:bsd-3)))
+
 (define-public python-plotille
   (package
     (name "python-plotille")