summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-07 02:10:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-07 02:11:00 +0200
commit6b4f87fa69af2bc2e4c8009e090717c7118b9aee (patch)
tree5fae47bb37b04c444741a616ebfbdb58eca02dd4
parent3dc591635e554fa4de452cf40d3c7f15e8f19fcc (diff)
downloadguix-6b4f87fa69af2bc2e4c8009e090717c7118b9aee.tar.gz
gnu: tinyproxy: Run tests.
* gnu/packages/web.scm (tinyproxy)[arguments]: Run the test suite.
[native-inputs]: Add perl.
-rw-r--r--gnu/packages/web.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ab733959e1..f735fa04a3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1644,7 +1644,8 @@ and other data, for distribution on the web.")
                 "0cizm8pbh5p557birdirkayj71xdxapaa9q29v1d4lf5qk7q3v61"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags
+     `(#:test-target "test"             ; ‘make check’ silently does nothing
+       #:configure-flags
        (list
         ;; For the log file, etc.
         "--localstatedir=/var")
@@ -1656,6 +1657,8 @@ and other data, for distribution on the web.")
              ;; (substitute* "docs/man5/Makefile" (("a2x") "a2x -v"))
              ;; (setenv "XML_DEBUG_CATALOG" "1")
              #t)))))
+    (native-inputs
+     `(("perl" ,perl)))                 ; for tests
     (home-page "https://tinyproxy.github.io/")
     (synopsis "Light-weight HTTP/HTTPS proxy daemon")
     (description "Tinyproxy is a light-weight HTTP/HTTPS proxy