summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-23 23:10:45 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-25 20:49:59 +0800
commit77cadb436be83557d17605565af1b17e574bdb68 (patch)
treec1adf13eaed8656ae33dc77b23fcf7eb72cdc00b
parentf5deff7a033e2b3fd0e8aceb094798e59f692d4c (diff)
downloadguix-77cadb436be83557d17605565af1b17e574bdb68.tar.gz
gnu: Add python-lazy-object-proxy and python2-lazy-object-proxy.
* gnu/packages/python.scm (python-lazy-object-proxy)
(python2-lazy-object-proxy): New variables.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d1d127bab9..dc9879a8f0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9419,3 +9419,26 @@ docstring and colored output.")
 (define-public python2-cleo
   (package-with-python2 python-cleo))
 
+(define-public python-lazy-object-proxy
+  (package
+    (name "python-lazy-object-proxy")
+    (version "1.2.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "lazy-object-proxy" version))
+              (sha256
+               (base32
+                "0s22aqqkdscyh8sjspyyax7qa1aiz8p4midrnyf39717fhfczm6x"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "https://github.com/ionelmc/python-lazy-object-proxy")
+    (synopsis "Lazy object proxy for python")
+    (description
+     "Lazy object proxy is an object that wraps a callable but defers the call
+until the object is actually required, and caches the result of said call.")
+    (license bsd-2)))
+
+(define-public python2-lazy-object-proxy
+  (package-with-python2 python-lazy-object-proxy))
+