summary refs log tree commit diff
diff options
context:
space:
mode:
authorZheng junjie <873216071@qq.com>2021-06-11 19:44:44 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-13 19:14:01 +0200
commit83e80943c86976c0758d14eaecb52fcc7f457d0c (patch)
tree53b09904ca74b295a9f42977650c5ece8f8661ff
parent89038e0234ad263da719c49822754407bec0378c (diff)
downloadguix-83e80943c86976c0758d14eaecb52fcc7f457d0c.tar.gz
gnu: Add rust-tikv-jemalloc-ctl-0.4.
* gnu/packages/crates-io.scm (rust-tikv-jemalloc-ctl-0.4): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 290390d1d5..9b904e75e4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -44953,6 +44953,39 @@ fixed set of worker threads.")
      "This package provides a Rust allocator backed by jemalloc.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-tikv-jemalloc-ctl-0.4
+  (package
+    (name "rust-tikv-jemalloc-ctl")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "tikv-jemalloc-ctl" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1pqs08dgnnrgbib8syldxmm8cjgyz80scs9i8jgn6mw86gj8137j"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-libc" ,rust-libc-0.2)
+        ("rust-paste" ,rust-paste-0.1)
+        ("rust-tikv-jemalloc-sys"
+         ,rust-tikv-jemalloc-sys-0.4))
+       #:cargo-development-inputs
+       (("rust-tikv-jemallocator"
+         ,rust-tikv-jemallocator-0.4))))
+    (home-page
+     "https://github.com/tikv/jemallocator")
+    (synopsis
+     "safe wrapper over jemalloc's control and introspection APIs")
+    (description
+     "This package provides a safe wrapper over jemalloc's control and
+introspection APIs.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-time-0.2
   (package
     (name "rust-time")