summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-18 22:32:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-19 22:33:21 +0200
commit87a3a185fe433d3497f08083c6ec7e5eb78c5fef (patch)
tree3eb89d198959648bfe3047e6ef0fedb3e38f557d
parent818794ee2832aa4c8395d758916e7c057cb02cfd (diff)
downloadguix-87a3a185fe433d3497f08083c6ec7e5eb78c5fef.tar.gz
gnu: Add rust-rustdoc-stripper-0.1.
* gnu/packages/crates-io.scm (rust-rustdoc-stripper-0.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index aaa3b2be2d..59d153dc22 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -14750,6 +14750,29 @@ require unstable language features.")
 rustc compiler.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-rustdoc-stripper-0.1
+  (package
+    (name "rust-rustdoc-stripper")
+    (version "0.1.9")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "rustdoc-stripper" version))
+        (file-name
+         (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "13rf65a0xk1zyb92jd8p12x529rsbfchwk9zvjr0snr9savpxw19"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-development-inputs
+       (("rust-tempfile" ,rust-tempfile-3.1))))
+    (home-page "https://github.com/GuillaumeGomez/rustdoc-stripper")
+    (synopsis "Nanipulate rustdoc comments")
+    (description
+     "This package provides a tool to manipulate rustdoc comments.")
+    (license license:asl2.0)))
+
 (define-public rust-rustfix-0.4
   (package
     (name "rust-rustfix")