summary refs log tree commit diff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-04-05 23:32:01 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-05 23:52:34 +0200
commit8b39565ca3606efb7c0b0e4ab0b1b3d530fb908f (patch)
tree7114b5051f3c1d8f7d4efe6552079a7ad0e278db
parent3496519f18dbd749d630b49989e2127f84b9918c (diff)
downloadguix-8b39565ca3606efb7c0b0e4ab0b1b3d530fb908f.tar.gz
gnu: synthv1: Make some inputs native.
* gnu/packages/music.scm (synthv1)[inputs]: Move qttools from here...
[native-inputs]: ...to here.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/music.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3b5f172dd4..0b9b6e52fa 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -25,6 +25,7 @@
 ;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
 ;;; Copyright © 2019 David Wilson <david@daviwil.com>
 ;;; Copyright © 2019, 2020 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1422,10 +1423,10 @@ users to select LV2 plugins and run them with jalv.")
        ("alsa-lib" ,alsa-lib)
        ("non-session-manager" ,non-session-manager)
        ("liblo" ,liblo)
-       ("qtbase" ,qtbase)
-       ("qttools" ,qttools)))
+       ("qtbase" ,qtbase)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("pkg-config" ,pkg-config)
+       ("qttools" ,qttools)))
     (home-page "https://synthv1.sourceforge.io")
     (synopsis "Polyphonic subtractive synthesizer")
     (description