summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-01-17 20:48:36 +0100
committerLudovic Courtès <ludo@gnu.org>2024-01-24 23:28:38 +0100
commit8bee6bb9aaaf35c36fe325675d1eb2daebd69c25 (patch)
treed14105efa06da4782c7e6e711516003a46fadbb0
parentf8e0e5274fcf9c966b3938d32922b569f48de524 (diff)
downloadguix-8bee6bb9aaaf35c36fe325675d1eb2daebd69c25.tar.gz
gnu: guile-fibers: Disable failing tests on aarch64.
* gnu/packages/guile-xyz.scm (guile-fibers)[arguments]: In
‘disable-some-tests’ phase, disable failing tests on aarch64.

Change-Id: Id05b516a659f641cc7ef01efdaf6cd1f2c735800
Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm30
1 files changed, 20 insertions, 10 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9c4c308d05..b90b86a53a 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -824,16 +824,26 @@ tables.")
            #~(list "GUILE_AUTO_COMPILE=0")
            #:phases
            (if (target-x86-64?)
-             #~%standard-phases
-             #~(modify-phases %standard-phases
-                 (add-before 'check 'disable-some-tests
-                   (lambda _
-                     ;; This test can take more than an hour on some systems.
-                     (substitute* "tests/basic.scm"
-                       ((".*spawn-fiber loop-to-1e4.*") ""))
-                     ;; These tests can take more than an hour and/or segfault.
-                     (substitute* "Makefile"
-                       (("tests/speedup.scm") ""))))))))
+               #~%standard-phases
+               #~(modify-phases %standard-phases
+                   (add-before 'check 'disable-some-tests
+                     (lambda _
+                       ;; This test can take more than an hour on some systems.
+                       (substitute* "tests/basic.scm"
+                         ((".*spawn-fiber loop-to-1e4.*") ""))
+
+                       ;; These tests can take more than an hour and/or segfault.
+                       (substitute* "Makefile"
+                         (("tests/speedup.scm") ""))
+
+                       (when #$(target-aarch64?)
+                         ;; The tests below have issues on aarch64 systems.
+                         ;; They pass on an Apple M1 but take a very long time
+                         ;; on a Hetzner aarch64 VM.  Skip them.
+                         (substitute* "tests/basic.scm"
+                           ((".*spawn-fiber-chain 5000000.*") ""))
+                         (substitute* "tests/channels.scm"
+                           ((".*assert-run-fibers-terminates .*pingpong.*") "")))))))))
     (native-inputs
      (list texinfo pkg-config autoconf-2.71 automake libtool
            guile-3.0            ;for 'guild compile