summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-11-27 18:25:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-11-27 18:29:44 +0100
commit8c4140e49e496bbf1d71331333127bf68e48e18e (patch)
tree0504dd09d473cffacc38e735aabc85d112596326
parentcd569f0d2989f7231939ad7446aea9942904dd09 (diff)
downloadguix-8c4140e49e496bbf1d71331333127bf68e48e18e.tar.gz
gnu: notmuch: Update to 0.23.3.
* gnu/packages/mail.scm (notmuch): Update to 0.23.3.
[arguments]: Re-enable previously failing tests.
-rw-r--r--gnu/packages/mail.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 9dcaea364c..e0d0fd164c 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -537,14 +537,14 @@ invoking @command{notifymuch} from the post-new hook.")
 (define-public notmuch
   (package
     (name "notmuch")
-    (version "0.23.2")
+    (version "0.23.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://notmuchmail.org/releases/notmuch-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1g4p5hsrqqbqk6s2w756als60wppvjgpyq104smy3w9vshl7bzgd"))))
+                "10hqjnl5aavf9clfmx3y832jyz58fplmc3f58pip9dq30b7sap8g"))))
     (build-system gnu-build-system)
     (arguments
      '(#:make-flags (list "V=1") ; Verbose test output.
@@ -568,11 +568,6 @@ invoking @command{notifymuch} from the post-new hook.")
                       ;; Patch various inline shell invocations.
                       (substitute* (find-files "test" "\\.sh$")
                         (("/bin/sh") (which "sh")))
-                      ;; XXX: Some signature verification tests fail with
-                      ;; gnupg-2.1.16, so we skip them. See this thread:
-                      ;; https://notmuchmail.org/pipermail/notmuch/2016/023688.html
-                      (setenv "NOTMUCH_SKIP_TESTS"
-                              "T350-crypto.2 T350-crypto.3 T350-crypto.4 T350-crypto.15")
                       #t)))))
     (native-inputs
      `(("bash-completion" ,bash-completion)