summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:45:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:54:48 +0300
commit9f92c8b51f099d90b1e1d834298319e17b04d829 (patch)
treede9284edda4468ec186f4bdac5ea5258ecb2d499
parent4541cda7d76b8fdea39b2abfda283e1e392d12fd (diff)
downloadguix-9f92c8b51f099d90b1e1d834298319e17b04d829.tar.gz
gnu: Add julia-pooledarrays.
* gnu/packages/julia-xyz.scm (julia-pooledarrays): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 82e7be95ab..35c3e416f1 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1597,6 +1597,28 @@ actual computation.")
 plotting components.")
     (license license:expat)))
 
+(define-public julia-pooledarrays
+  (package
+    (name "julia-pooledarrays")
+    (version "1.2.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaData/PooledArrays.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0ihvhzkxdw4qf0i6sbrickhdcwkmlin9zyixxn9xvgzm8nc0iwqy"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     `(("julia-dataapi" ,julia-dataapi)))
+    (home-page "https://github.com/JuliaData/PooledArrays.jl")
+    (synopsis "Pooled representation of arrays in Julia")
+    (description "This package provides a pooled representation of arrays for
+purposes of compression when there are few unique elements.")
+    (license license:expat)))
+
 (define-public julia-quadmath
   (package
     (name "julia-quadmath")