summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-09-20 11:31:51 +0000
committerChristopher Baines <mail@cbaines.net>2017-10-14 07:18:19 +0100
commita4593cc95bb45878ad44b9761d6b6962532da409 (patch)
tree05c44e5012ea423d0278c49e6aa585d82b2226e4
parentaf6ce6108818eca78def159c8e6f8c14b0272978 (diff)
downloadguix-a4593cc95bb45878ad44b9761d6b6962532da409.tar.gz
gnu: python-fonttools: Update to 3.15.1.
* gnu/packages/python.scm (python-fonttools): Update to 3.15.1.
  (source)[uri]: Use 'pypi-uri'.
  (native-inputs): Add unzip.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 44504e3833..1b62668904 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7421,15 +7421,13 @@ add functionality and customization to your projects with their own plugins.")
 (define-public python-fonttools
   (package
     (name "python-fonttools")
-    (version "2.5")
+    (version "3.15.1")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                    "https://pypi.python.org/packages/source/F/FontTools/"
-                    "fonttools-" version ".tar.gz"))
+              (uri (pypi-uri "fonttools" version ".zip"))
               (sha256
                (base32
-                "08ay3x4ijarwhl60gqx2i9jzq6pxs20p4snc2d1q5jagh4rn39lb"))))
+                "1hhj97izwliy0vybmza72d90l5d4mcn50y8akq7kyccfl82vdx4d"))))
     (build-system python-build-system)
     (arguments
      '(#:test-target "check"
@@ -7443,6 +7441,8 @@ add functionality and customization to your projects with their own plugins.")
              (substitute* "setup.py"
                (("^[ \t]*extra_path *= *'FontTools',") ""))
              #t)))))
+    (native-inputs
+     `(("unzip" ,unzip)))
     (home-page "https://github.com/behdad/fonttools")
     (synopsis "Tools to manipulate font files")
     (description