summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-04 18:43:09 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-08 18:59:49 +0200
commitab313cd0ba59098e7b88627a223204bacd3a7eb9 (patch)
tree38548314352c51b75c7564c59b43d23b0e007977
parent73a3598df8dc86ed72d0779c8db0932fa69952c7 (diff)
downloadguix-ab313cd0ba59098e7b88627a223204bacd3a7eb9.tar.gz
gnu: sonnet: Add optional input (spell-checker).
* gnu/packages/kde-frameworks.scm (sonnet)[inputs]: Add hunspell; add
  todo comment for other language's spell-checker.
-rw-r--r--gnu/packages/kde-frameworks.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 1aa438b77d..c5b14eae7f 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -47,6 +47,7 @@
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages image)
   #:use-module (gnu packages kerberos)
+  #:use-module (gnu packages libreoffice)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages mp3)
   #:use-module (gnu packages pdf)
@@ -1192,7 +1193,9 @@ system.")
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("qttools" ,qttools)))
     (inputs
-     `(("qtbase" ,qtbase)))
+     `(("hunspell" ,hunspell)
+       ;; TODO: hspell (for Hebrew), Voikko (for Finish)
+       ("qtbase" ,qtbase)))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Multi-language spell checker")
     (description "Sonnet is a plugin-based spell checking library for Qt-based