summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-30 01:58:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-30 03:46:17 +0200
commitaf029a80dd0e81be65b05ffa9a68c7ee43a62ae9 (patch)
tree1a36a7e3b9391c3fbeb93d1581d9fa21a9438f55
parentd5ed14bdda200dd98aa770eb9c2c883392fe15e2 (diff)
downloadguix-af029a80dd0e81be65b05ffa9a68c7ee43a62ae9.tar.gz
gnu: python2-xopen: Fix build.
* gnu/packages/python.scm (python2-xopen)[propagated-inputs]: Add
python2-bz2file.
-rw-r--r--gnu/packages/python.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d4e01202b5..b05911db56 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10446,7 +10446,12 @@ possible on all supported Python versions.")
     (license license:expat)))
 
 (define-public python2-xopen
-  (package-with-python2 python-xopen))
+  (let ((base (package-with-python2
+               (strip-python2-variant python-xopen))))
+    (package
+      (inherit base)
+      (propagated-inputs `(("python2-bz2file" ,python2-bz2file)
+                           ,@(package-propagated-inputs base))))))
 
 (define-public python2-cheetah
   (package