summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 13:27:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 13:27:32 +0200
commitb04a2efe46319dff0377f842b862ddb3a7a93543 (patch)
tree0edc488e2252e3f4c79aea195b83a5e8fc02f2d6
parent84392227e3e6646d2c01f08dcb774f30cbda10a1 (diff)
downloadguix-b04a2efe46319dff0377f842b862ddb3a7a93543.tar.gz
gnu: Add r-drtmle.
* gnu/packages/cran.scm (r-drtmle): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 23760bceb5..8d36bdebfb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9761,6 +9761,33 @@ Models\" (Hastie and Tibshirani, 1990).")
 a library of prediction algorithms to be used in the super learner.")
     (license license:gpl3)))
 
+(define-public r-drtmle
+  (package
+    (name "r-drtmle")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "drtmle" version))
+       (sha256
+        (base32
+         "08a6k0nrg6mqdslwjc71583x52vnax87nbfalk98zczwvrrdwvxa"))))
+    (properties `((upstream-name . "drtmle")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-future-apply" ,r-future-apply)
+       ("r-np" ,r-np)
+       ("r-superlearner" ,r-superlearner)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/benkeser/drtmle")
+    (synopsis "Doubly-robust nonparametric estimation and inference")
+    (description
+     "This package implements targeted minimum loss-based estimators of
+counterfactual means and causal effects that are doubly-robust with respect
+both to consistency and asymptotic normality.")
+    (license license:expat)))
+
 (define-public r-mosaiccore
   (package
     (name "r-mosaiccore")