summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 15:36:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:08 +0200
commitb1554676a0af15b4eca217a4f7e5fbba47691cf5 (patch)
treec081e243553a2030e7f71c9c4faf8c301034d608
parentb8cd24eebd1bde52872bd2bbf71532e2e1e23a4f (diff)
downloadguix-b1554676a0af15b4eca217a4f7e5fbba47691cf5.tar.gz
gnu: texlive-carlisle: Refresh package definition.
* gnu/packages/tex.scm (texlive-carlisle): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[propagated-inputs]: Add TEXLIVE-GRAPHICS, TEXLIVE-TOOLS.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 17 insertions, 10 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fb3b058589..5a63a77925 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6095,21 +6095,28 @@ to something that's not a float.")
 
 (define-public texlive-carlisle
   (package
-    (inherit (simple-texlive-package
-              "texlive-carlisle"
-              (list "doc/latex/carlisle/"
-                    "source/latex/carlisle/"
-                    "tex/latex/carlisle/")
-              (base32 "139k4n8dv6pbal1mx4m8b239x3i9cw61f6digk9mxscbxwvxfngb")
-              #:trivial? #t))
-    (home-page "https://ctan.org/macros/latex/contrib/carlisle")
+    (name "texlive-carlisle")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/carlisle/" "source/latex/carlisle/"
+                   "tex/latex/carlisle/")
+             (base32
+              "139k4n8dv6pbal1mx4m8b239x3i9cw61f6digk9mxscbxwvxfngb")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-graphics
+           texlive-tools))
+    (home-page "https://ctan.org/pkg/carlisle")
     (synopsis "David Carlisle's small packages")
     (description
      "Many of David Carlisle's more substantial packages stand on their own,
 or as part of the LaTeX latex-tools set; this set contains: making dotless
 @emph{j} characters for fonts that don't have them; a method for combining the
-capabilities of longtable and tabularx; an environment for including plain TeX
-in LaTeX documents; a jiffy to create slashed characters for physicists.")
+capabilities of @code{longtable} and @code{tabularx}; an environment for
+including plain TeX in LaTeX documents; a jiffy to create slashed characters
+for physicists.")
     (license license:lppl)))
 
 (define-public texlive-catchfile