summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 18:43:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:29 +0200
commitc124a4bbc9ed8a4b9cb27bc70750de20b8a3edc5 (patch)
treeada6126215e220f013ae58645157f4d0aece5f3c
parent005b3bf3cd474f92768280d1df6baf8a707bd501 (diff)
downloadguix-c124a4bbc9ed8a4b9cb27bc70750de20b8a3edc5.tar.gz
gnu: Add texlive-context-vim.
* gnu/packages/tex.scm (texlive-context-vim): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6afb2b07a4..7312b12381 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10627,6 +10627,32 @@ fonts (or collections of fonts from the same foundry); each is available in
 a @file{.mkii} and a @file{.mkiv} version.")
     (license license:gpl2)))
 
+(define-public texlive-context-vim
+  (package
+    (name "texlive-context-vim")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/context/third/vim/"
+                   "tex/context/third/vim/")
+             (base32
+              "03cwdqkrx6bgcikmyxrwkyac3jmz7i50cavgb6r8b26zrsm522ca")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-context texlive-context-filter))
+    (home-page "https://ctan.org/pkg/context-vim")
+    (synopsis "Generate ConTeXt syntax highlighting code from Vim")
+    (description
+     "ConTeXt has excellent pretty printing capabilities for many languages.
+The code for pretty printing is written in TeX, and due to catcode juggling,
+such verbatim typesetting is perhaps the trickiest part of TeX.  This makes it
+difficult for a normal user to define syntax highlighting rules for a new
+language.  This module takes the onus of defining syntax highlighting rules
+away from the user and uses Vim editor to generate the syntax highlighting.
+There is a helper @file{2context.vim} script to do the syntax parsing in
+Vim.")
+    (license license:bsd-2)))
+
 (define-public texlive-beamer
   (package
     (name "texlive-beamer")