summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-18 22:21:21 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-19 00:48:20 +0100
commitc3ee7448c9c10d0fdcc52fd1d57031cf6677aafc (patch)
tree751090e9eacb6c554d467f77d8f464260ad4668c
parent45298f8fd28635763507417e6ac026a52d51c060 (diff)
downloadguix-c3ee7448c9c10d0fdcc52fd1d57031cf6677aafc.tar.gz
build-system/gnu: Change the order of `patch-source-shebangs' and `patch'.
* guix/build/gnu-build-system.scm (patch-source-shebangs): Add a newline
  after the "SHELL =" line in po/Makefile.in.in.
  (%standard-phases): Move `patch-source-shebangs' after `patch'.
-rw-r--r--guix/build/gnu-build-system.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index b67918552c..5e899403e8 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -98,7 +98,7 @@
     (when (file-exists? "po/Makefile.in.in")
       (substitute* "po/Makefile.in.in"
         (("^SHELL[[:blank:]]*=.*$")
-         (string-append "SHELL = " bash))))))
+         (string-append "SHELL = " bash "\n"))))))
 
 (define* (patch #:key (patches '()) (patch-flags '("--batch" "-p1"))
                 #:allow-other-keys)
@@ -249,7 +249,7 @@
   ;; Standard build phases, as a list of symbol/procedure pairs.
   (let-syntax ((phases (syntax-rules ()
                          ((_ p ...) `((p . ,p) ...)))))
-    (phases set-paths unpack patch-source-shebangs patch configure
+    (phases set-paths unpack patch patch-source-shebangs configure
             build check install
             patch-shebangs strip)))