summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-05-25 22:14:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-06-12 23:01:33 +0200
commitccb8da2654ed4dc570c385331fafb9673d5ae452 (patch)
tree78846800f84d5ba5fd98567598c594bc0400f7ee
parent76e146384c3465beb5cdbfad05c31bd79808a668 (diff)
downloadguix-ccb8da2654ed4dc570c385331fafb9673d5ae452.tar.gz
gnu: Add RapidJSON.
* gnu/packages/web.scm (rapidjson): New variable.
-rw-r--r--gnu/packages/web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e77bad76d6..6660c3fe8e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -259,6 +259,27 @@ easily construct JSON objects in C, output them as JSON formatted strings and
 parse JSON formatted strings back into the C representation of JSON objects.")
     (license l:x11)))
 
+(define-public rapidjson
+  (package
+    (name "rapidjson")
+    (version "1.0.2")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "https://github.com/miloyip/rapidjson/archive/v"
+                   version ".tar.gz"))
+             (file-name (string-append name "-" version ".tar.gz"))
+             (sha256
+              (base32
+               "0rl6s0vg5y1dhh9vfl1lqay3sxf69sxjh0czxrjmasn7ng91wwf3"))))
+    (build-system cmake-build-system)
+    (home-page "https://github.com/miloyip/rapidjson")
+    (synopsis "JSON parser/generator for C++ with both SAX/DOM style API")
+    (description
+     "RapidJSON is a fast JSON parser/generator for C++ with both SAX/DOM
+style API.")
+    (license l:expat)))
+
 (define-public libwebsockets
   (package
     (name "libwebsockets")