summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-02-17 13:23:00 -0500
committerLeo Famulari <leo@famulari.name>2019-02-19 14:34:30 -0500
commitd5bbf66d71322fc9bc32adfeb41ab733ec47502b (patch)
tree85d0e94a9a85794b6bae3f59275c4306dc9ef083
parentb742c0065645837f9675ca16b1ad21da89544477 (diff)
downloadguix-d5bbf66d71322fc9bc32adfeb41ab733ec47502b.tar.gz
gnu: Add python-txaio.
* gnu/packages/python-xyz.scm (python-txaio): New variable.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c18b1e954b..269090c764 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15060,3 +15060,24 @@ make your work easier.")
 and dates in \"human readable\" forms.  For example, it would display
 \"12345591313\" as \"12.3 billion\".")
     (license license:expat)))
+
+(define-public python-txaio
+  (package
+    (name "python-txaio")
+    (version "18.8.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "txaio" version))
+        (sha256
+         (base32
+          "1zmpdph6zddgrnkkcykh6qk5s46l7s5mzfqrh82m4b5iffn61qv7"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-twisted" ,python-twisted)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/crossbario/txaio")
+    (synopsis "Compatibility layer between Python asyncio and Twisted")
+    (description "Txaio provides a compatibility layer between the Python
+@code{asyncio} module and @code{Twisted}.")
+    (license license:expat)))