summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-24 10:41:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-24 10:41:50 +0300
commitd739b8d8b8c4fa49d3a49f218cb8b8e111715ec1 (patch)
tree11caabbfe2eb35fc40956b947bf21088199bdc19
parent2d84ef328cfa19743d97dde5929ec2d5fc00f12e (diff)
downloadguix-d739b8d8b8c4fa49d3a49f218cb8b8e111715ec1.tar.gz
gnu: libsignal-protocol-c: Don't use unstable tarball.
* gnu/packages/messaging.scm (libsignal-protocol-c)[source]: Download
using git-fetch.
-rw-r--r--gnu/packages/messaging.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index a03c620574..8ac03ef6b9 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -155,14 +155,14 @@ keys, no previous conversation is compromised.")
   (name "libsignal-protocol-c")
   (version "2.3.2")
   (source (origin
-           (method url-fetch)
-           (uri (string-append "https://github.com/WhisperSystems/"
-                               "libsignal-protocol-c/archive/v" version
-                               ".tar.gz"))
-           (file-name (string-append name "-" version ".tar.gz"))
+           (method git-fetch)
+           (uri (git-reference
+                  (url "https://github.com/WhisperSystems/libsignal-protocol-c")
+                  (commit (string-append "v" version))))
+           (file-name (git-file-name name version))
            (sha256
             (base32
-             "0380hl6fw3ppf265fg897pyrpqygpx4m9j8ifq118bim8lq6z0pk"))))
+             "1qj2w4csy6j9jg1jy66n1qwysx7hgjywk4n35hlqcnh1kpa14k3p"))))
   (arguments
    `(;; Required for proper linking and for tests to run.
      #:configure-flags '("-DBUILD_SHARED_LIBS=on" "-DBUILD_TESTING=1")))