summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-13 10:31:49 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-17 12:29:58 +0100
commitddd82e0e763a84dd840cc724591af5574978c210 (patch)
tree05be5b8138a0189cc1703fe31c57cd66fc229c52
parent9a8336d87b0bd343da9f51ca3964f359a26fbf72 (diff)
downloadguix-ddd82e0e763a84dd840cc724591af5574978c210.tar.gz
gnu: Add MISO.
* gnu/packages/bioinformatics.scm (miso): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2e786b3290..1214a0b708 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -570,6 +570,51 @@ resolution of binding sites through combining the information of both
 sequencing tag position and orientation.")
     (license license:bsd-3)))
 
+(define-public miso
+  (package
+    (name "miso")
+    (version "0.5.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://pypi.python.org/packages/source/m/misopy/misopy-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0x446867az8ir0z8c1vjqffkp0ma37wm4sylixnkhgawllzx8v5w"))
+              (modules '((guix build utils)))
+              ;; use "gcc" instead of "cc" for compilation
+              (snippet
+               '(substitute* "setup.py"
+                  (("^defines")
+                   "cc.set_executables(
+compiler='gcc',
+compiler_so='gcc',
+linker_exe='gcc',
+linker_so='gcc -shared'); defines")))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2 ; only Python 2 is supported
+       #:tests? #f)) ; no "test" target
+    (inputs
+     `(("samtools" ,samtools)
+       ("python-numpy" ,python2-numpy)
+       ("python-pysam" ,python2-pysam)
+       ("python-scipy" ,python2-scipy)
+       ("python-matplotlib" ,python2-matplotlib)))
+    (native-inputs
+     `(("python-setuptools" ,python2-setuptools)))
+    (home-page "http://genes.mit.edu/burgelab/miso/index.html")
+    (synopsis "Mixture of Isoforms model for RNA-Seq isoform quantitation")
+    (description
+     "MISO (Mixture-of-Isoforms) is a probabilistic framework that quantitates
+the expression level of alternatively spliced genes from RNA-Seq data, and
+identifies differentially regulated isoforms or exons across samples.  By
+modeling the generative process by which reads are produced from isoforms in
+RNA-Seq, the MISO model uses Bayesian inference to compute the probability
+that a read originated from a particular isoform.")
+    (license license:gpl2)))
+
 (define-public rseqc
   (package
     (name "rseqc")