summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 23:28:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-08 08:53:50 +0100
commite0f1aa2d2b09d9baa69cd6b69735671f694b1f8b (patch)
treeac2331f8b8eac86b92d702b1cbee33e8f982cba6
parented33049cdc4231baa35de4197646a7117d4082df (diff)
downloadguix-e0f1aa2d2b09d9baa69cd6b69735671f694b1f8b.tar.gz
gnu: tadbit: Fetch sources from git.
* gnu/packages/bioinformatics.scm (tadbit)[source]: Fetch from git.
[version]: Use "2.0.0" instead of "2.0".
-rw-r--r--gnu/packages/bioinformatics.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0c2e0b50c1..bbdecbff43 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11503,15 +11503,16 @@ applications for tackling some common problems in a user-friendly way.")
 (define-public tadbit
   (package
     (name "tadbit")
-    (version "0.2")
+    (version "0.2.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/3DGenomes/TADbit/"
-                                  "archive/v" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/3DGenomes/TADbit.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1cnfqrl4685zar4nnw94j94nhvl2h29jm448nadqi1h05z6fdk4f"))))
+                "07g3aj648prmsvxp9caz5yl41k0y0647vxh0f5p3w8376mfiljd0"))))
     (build-system python-build-system)
     (arguments
      `(;; Tests are included and must be run after installation, but