summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-11-15 23:27:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-11-15 23:31:35 +0100
commite1fa3ea9fe8d01dd124c5e304bde9243876378ba (patch)
treeedb66ad82aca89989235c8406909be314865c5ab
parentf11c9a89193e72ee11df585cd08f1edffb9f6e48 (diff)
downloadguix-e1fa3ea9fe8d01dd124c5e304bde9243876378ba.tar.gz
gnu: methyldackel: Update to 0.5.1.
* gnu/packages/bioinformatics.scm (methyldackel): Update to 0.5.1.
[arguments]: Link with libbigwig.
[inputs]: Add curl and libbigwig; replace htslib with htslib-1.9.
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 15230a8ef2..91fcb28451 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15437,7 +15437,7 @@ patterns.")
 (define-public methyldackel
   (package
     (name "methyldackel")
-    (version "0.4.0")
+    (version "0.5.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -15446,7 +15446,7 @@ patterns.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "10gh8k0ca92kywnrw5pkacq3g6r8s976s12k8jhp8g3g49q9a97g"))))
+                "1sfhf2ap75qxpnmy1ifgmxqs18rq8mah9mcgkby73vc6h0sw99ws"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
@@ -15459,11 +15459,14 @@ patterns.")
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              (substitute* "Makefile"
+               (("-lhts ") "-lhts -lBigWig ")
                (("install MethylDackel \\$\\(prefix\\)" match)
                 (string-append "install -d $(prefix); " match)))
              #t)))))
     (inputs
-     `(("htslib" ,htslib)
+     `(("curl" ,curl) ; XXX: needed by libbigwig
+       ("htslib" ,htslib-1.9)
+       ("libbigwig" ,libbigwig)
        ("zlib" ,zlib)))
     ;; Needed for tests
     (native-inputs