summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-03 00:04:11 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:58:59 +0100
commite554eba02c8f5fc090ca54476a0ad6a1de9cc5c0 (patch)
tree839ecaecb74bafc3643cc38b10a819398330d1fe
parentf3e00778d8c949ee28266d6b362a04905dd70496 (diff)
downloadguix-e554eba02c8f5fc090ca54476a0ad6a1de9cc5c0.tar.gz
gnu: OpenSSL: Incorporate grafted changes.
* gnu/packages/tls.scm (openssl): Update to 1.1.1d.
[replacement]: Remove field.
(openssl-1.1.1d): Remove variable.
-rw-r--r--gnu/packages/tls.scm23
1 files changed, 2 insertions, 21 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index da9ba9346f..7e1bf832ba 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -300,8 +300,7 @@ required structures.")
 (define-public openssl
   (package
    (name "openssl")
-   (version "1.1.1c")
-   (replacement openssl-1.1.1d)
+   (version "1.1.1d")
    (source (origin
              (method url-fetch)
              (uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -313,7 +312,7 @@ required structures.")
                                        "/openssl-" version ".tar.gz")))
              (sha256
               (base32
-               "142c7zdlz06hjrrvinb9f276czc78bnkyhd9xma621qmmmwk1yzn"))
+               "1whinyw402z3b9xlb3qaxv4b9sk4w1bgh9k0y8df1z4x3yy92fhy"))
              (patches (search-patches "openssl-1.1-c-rehash-in.patch"))))
    (build-system gnu-build-system)
    (outputs '("out"
@@ -425,24 +424,6 @@ required structures.")
    (license license:openssl)
    (home-page "https://www.openssl.org/")))
 
-(define openssl-1.1.1d
-  (package/inherit
-   openssl
-   (version "1.1.1d")
-   (source (origin
-             (method url-fetch)
-             (uri (list (string-append "https://www.openssl.org/source/openssl-"
-                                       version ".tar.gz")
-                        (string-append "ftp://ftp.openssl.org/source/"
-                                       "openssl-" version ".tar.gz")
-                        (string-append "ftp://ftp.openssl.org/source/old/"
-                                       (string-trim-right version char-set:letter)
-                                       "/openssl-" version ".tar.gz")))
-             (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
-             (sha256
-              (base32
-               "1whinyw402z3b9xlb3qaxv4b9sk4w1bgh9k0y8df1z4x3yy92fhy"))))))
-
 (define-public openssl-1.0
   (package
     (inherit openssl)