summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-01 21:30:56 -0400
committerLeo Famulari <leo@famulari.name>2016-11-01 21:46:06 -0400
commite777d07db90a64adc4cd7c22ae921aa03bb3fc49 (patch)
treeee418d59296a49be24cd2a2a2e607c5a51ae46d7
parent2c1d46b257fdbdfbb6fb8746abe426150fc3fbab (diff)
downloadguix-e777d07db90a64adc4cd7c22ae921aa03bb3fc49.tar.gz
gnu: iproute2: Update to 4.8.0.
* gnu/packages/linux.scm (iproute2): Update to 4.8.0.
[arguments]: Set Bash completion directory in #:make-flags.
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8f0a9ab0e4..dff36a3bdc 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -900,7 +900,7 @@ packet filter.")
 (define-public iproute
   (package
     (name "iproute2")
-    (version "4.4.0")
+    (version "4.8.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -908,12 +908,14 @@ packet filter.")
                     version ".tar.xz"))
               (sha256
                (base32
-                "05351m4m0whsivlblvs3m0nz5q9v6r06ik80z27gf6ca51kw74dw"))))
+                "12dk5hn1zlraqk2p0z8dv2xgsz0x9v8l3vcvf51fzj0v8b45j2d3"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                                ; no test suite
        #:make-flags (let ((out (assoc-ref %outputs "out")))
                       (list "DESTDIR="
+                            (string-append "BASH_COMPDIR=" out
+                                           "/etc/bash_completion.d")
                             (string-append "LIBDIR=" out "/lib")
                             (string-append "SBINDIR=" out "/sbin")
                             (string-append "CONFDIR=" out "/etc")