summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-24 13:18:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-11-24 22:30:09 +0200
commiteb31d4b4f12d82b3cd8ab04c0e8a796322e6abbc (patch)
tree37c65cbb87c686ef55b42cb27ba13d6bb8dc31c0
parentd50d097d58a4df1b575f1239c11cd6b57fde68cf (diff)
downloadguix-eb31d4b4f12d82b3cd8ab04c0e8a796322e6abbc.tar.gz
gnu: python-pyjwt: Update to 1.4.0.
* gnu/packages/python.scm (python-pyjwt): Update to 1.4.0.
[native-inputs]: Move python-setuptools here, add python-pytest-runner.
-rw-r--r--gnu/packages/python.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bab64612b0..6d1a8e0d0f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2159,19 +2159,18 @@ somewhat intelligeble.")
 (define-public python-pyjwt
   (package
     (name "python-pyjwt")
-    (version "0.2.1")
+    (version "1.4.0")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "https://pypi.python.org/packages/source/P/PyJWT/PyJWT-"
-             version ".tar.gz"))
+       (uri (pypi-uri "PyJWT" version))
        (sha256
         (base32
-         "1ahqblfy2sj3xz34wsa48cn9rp0dspzq56p54i5znmws3b8gml6g"))))
+         "1556v2jppd8mjkkj66pxb5rcazm35jq81r233mdl8hfmz9n3icp1"))))
     (build-system python-build-system)
-    (inputs
-     `(("python-setuptools" ,python-setuptools)))
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)
+       ("python-pytest-runner" ,python-pytest-runner)))
     (arguments
      '(#:tests? #f)) ; test suite doesn't work
     (home-page "http://github.com/progrium/pyjwt")