summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-02 21:46:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-09 22:17:39 -0400
commitf4271bbd79e5a85cdb32f4d79d6bb4d8c4739c69 (patch)
treeb837538bd5c3763e9c487e9ad2a7ab436ead6342
parent431e641b83a7b3371e38c949095de448db576f22 (diff)
downloadguix-f4271bbd79e5a85cdb32f4d79d6bb4d8c4739c69.tar.gz
Revert commits made to resolve a gdk-pixbuf+svg propagation issue.
Fixes <https://issues.guix.gnu.org/50957>.

This reverts the following commits:

 - 42231bc (gnu: cheese: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - ad6a950 (gnu: mutter: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - 5e02d1a (gnu: cogl: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - 5c467b2 (gnu: libgweather: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - 26487f6 (gnu: librsvg-next: Do not propagate gdk-pixbuf)
 - d891922 (gnu: librsvg: Do not propagate gdk-pixbuf)
 - 22476d3 (gnu: libgsf: Do not propagate gdk-pixbuf)
 - 099ca0e (gnu: libnotify: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - fb6a1ff (gnu: appstream-glib: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - 4fb525d (gnu: weasyprint: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)

These commits were made to resolve a gdk-pixbuf loaders clash that could occur
in a profile when both gdk-pixbuf and gdk-pixbuf+svg were propagated.
Unfortunately, librsvg really needs to propagate gdk-pixbuf itself, which
would introduce a cycle.  Packages such as 'efl' were broken as a result of
not propagating gdk-pixbuf.

A more definitive fix will be proposed for core-updates, which includes a
profile hook to generate the gdk-pixbuf loaders.cache file, as well as a build
phase and search path specification, that should resolve the issue for good.
-rw-r--r--gnu/packages/glib.scm4
-rw-r--r--gnu/packages/gnome.scm20
-rw-r--r--gnu/packages/pdf.scm4
3 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 79d2930101..d264d66b92 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -9,7 +9,7 @@
 ;;; Copyright © 2017 Petter <petter@mykolab.ch>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2019, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
@@ -1087,7 +1087,7 @@ Some codes examples can be find at:
        ("pkg-config" ,pkg-config)))
     (propagated-inputs
      `(("gcab" ,gcab) ; for .pc file
-       ("gdk-pixbuf" ,gdk-pixbuf+svg) ; for .pc file
+       ("gdk-pixbuf" ,gdk-pixbuf) ; for .pc file
        ("libuuid" ,util-linux "lib"))) ; for .pc file
     (inputs
      `(("glib" ,glib)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4df79bb442..a71e7f86dd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3063,7 +3063,7 @@ configuring CUPS.")
              #t)))))
     (propagated-inputs
      `(;; In Requires of libnotify.pc.
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)))
     (inputs
      `(("gtk+" ,gtk+)
@@ -3286,11 +3286,11 @@ XML/CSS rendering engine.")
        ("perl" ,perl)
        ("perl-xml-parser" ,perl-xml-parser)))
     (inputs
-     `(("gdk-pixbuf" ,gdk-pixbuf)
-       ("zlib" ,zlib)
+     `(("zlib" ,zlib)
        ("bzip2" ,bzip2)))
     (propagated-inputs
-     `(("glib" ,glib)
+     `(("gdk-pixbuf" ,gdk-pixbuf)
+       ("glib" ,glib)
        ("libxml2" ,libxml2)))
     (home-page "https://www.gnome.org/projects/libgsf")
     (synopsis "GNOME's Structured File Library")
@@ -3357,11 +3357,11 @@ dealing with different structured file formats.")
        ("libcroco" ,libcroco)
        ("bzip2" ,bzip2)
        ("libgsf" ,libgsf)
-       ("gdk-pixbuf" ,gdk-pixbuf)
        ("libxml2" ,libxml2)))
     (propagated-inputs
      ;; librsvg-2.0.pc refers to all of that.
      `(("cairo" ,cairo)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)))
     (home-page "https://wiki.gnome.org/LibRsvg")
     (synopsis "Render SVG files using Cairo")
@@ -3536,7 +3536,6 @@ library.")
      `(("bzip2" ,bzip2)
        ("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
-       ("gdk-pixbuf" ,gdk-pixbuf)
        ("harfbuzz" ,harfbuzz)
        ("libcroco" ,libcroco)
        ("libgsf" ,libgsf)
@@ -3544,6 +3543,7 @@ library.")
        ("pango" ,pango)))
     (propagated-inputs
      `(("cairo" ,cairo)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)))
     (synopsis "SVG rendering library")
     (description "Librsvg is a library to render SVG images to Cairo surfaces.
@@ -5446,7 +5446,7 @@ service via the system message bus.")
      ;; gweather-3.0.pc refers to GTK+, GDK-Pixbuf, GLib/GObject, libxml, and
      ;; libsoup.
      `(("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("libxml2" ,libxml2)
        ("libsoup" ,libsoup)
        ("geocode-glib" ,geocode-glib)))
@@ -5711,7 +5711,7 @@ throughout GNOME for API documentation).")
        ("pkg-config" ,pkg-config)))
     (propagated-inputs
      `(("glib" ,glib)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("libx11" ,libx11)
        ("libxext" ,libxext)
        ("libxfixes" ,libxfixes)
@@ -7384,7 +7384,7 @@ to display dialog boxes from the commandline and shell scripts.")
        ;; mutter-clutter-1.0.pc and mutter-cogl-1.0.pc refer to these:
        ("atk" ,atk)
        ("cairo" ,cairo)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)
        ("json-glib" ,json-glib)
        ("libinput" ,libinput)
@@ -10484,7 +10484,7 @@ photo-booth-like software, such as Cheese.")
        ("clutter-gst" ,clutter-gst)
        ("clutter-gtk" ,clutter-gtk)
        ("libcanberra" ,libcanberra)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)
        ("gstreamer" ,gstreamer)))
     (inputs
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 78b52a44f8..a5b5442f29 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -20,7 +20,7 @@
 ;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
-;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1525,7 +1525,7 @@ manipulating PDF documents from the command line.  It supports
        ("glib" ,glib)
        ("pango" ,pango)))
     (propagated-inputs
-     `(("gdk-pixbuf" ,gdk-pixbuf+svg)
+     `(("gdk-pixbuf" ,gdk-pixbuf)
        ("python-cairocffi" ,python-cairocffi)
        ("python-cairosvg" ,python-cairosvg)
        ("python-cffi" ,python-cffi)