summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 14:39:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:49 +0100
commitf79e63a57149bf1972aedfb088e7139b7af78ffd (patch)
tree24a376103f9d89c53ba6aa1196cd02fe3784df6d
parentb2e777b27cb677592f7a72fef491ec476d7ae65a (diff)
downloadguix-f79e63a57149bf1972aedfb088e7139b7af78ffd.tar.gz
gnu: Add r-rnifti.
* gnu/packages/cran.scm (r-rnifti): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 16d576ecee..a4b4897fd9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9050,3 +9050,26 @@ a given p-value.  It is an interface to code originally made available by
 Helene Touzet and Jean-Stephane Varre, 2007, Algorithms Mol Biol:2, 15.
 Touzet and Varre (2007).")
     (license license:gpl2)))
+
+(define-public r-rnifti
+  (package
+    (name "r-rnifti")
+    (version "0.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RNifti" version))
+       (sha256
+        (base32
+         "07sfzps4yg5zdhbxh6i4rbjvbjvvf2d8i9jcf64ywbmi557sw1zv"))))
+    (properties `((upstream-name . "RNifti")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/jonclayden/RNifti")
+    (synopsis "Fast R and C++ access to NIfTI images")
+    (description
+     "This package provides very fast read and write access to images stored
+in the NIfTI-1 and ANALYZE-7.5 formats, with seamless synchronisation between
+compiled C and interpreted R code.  It also provides a C/C++ API that can be
+used by other packages.")
+    (license license:gpl2)))